VMware Workstation 8 “Micro-Freezes”

I ran into this issue recently, and even though the answer was out there, it took me a while to find the right fix. Here it is again…

Symptom

I built an admin workstation for work but soon noticed what others were calling “micro-freezes” while using the virtual machine. The virtual machine’s responsiveness was great, however, it would frequently hang for ~5-10 seconds. For me, the annoyance made it unusable.

I thought it may have been an issue with the base version of WS8 I was using, but the problem persisted even after updating to the latest patch (8.0.4 build-744019 at the time of writing)

Here is a post on the VMware communities forum that identified a few workarounds for the issue. See below for a screenshot of the setting to disable.

VMware Communities post

Cause (3D Acceleration)

I have a pretty low-end graphics card in my PC (NVIDIA GeForce 9500GT) which may have caused the 3D acceleration lag. Disabling it reduces the fluidness of the virtual machine for graphics/windowing, but fixes the constant freezing. For my purposes, this is acceptable.

Resolution

Disable the virtual machines “3D Acceleration”.

1. Select “VM->Settings” from the main-menu

2. Select “Display” and UNCHECK the “Accelerate 3D graphics” checkbox.

3. Enjoy!

image

I hope this helps!

Ubergiek

Comments 2

  1. Thank you! We have been looking for a ‘fix’ for this problem for a long, long time. Never thought to look, or just didn’t notice that the 3D Acceleration box was checked. Once again thank you very much. We have included this info on our Web Page with reference to your page here.

    1. Post
      Author

      I am glad this helped solve your issue. It pained me for a while and was just annoying enough for me to run the problem down. Thanks again for visiting!

      – Ubergiek

Leave a Reply

Your email address will not be published. Required fields are marked *

*